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Dense Point Clouds and Surface Models in Agisoft Metashape 
Objective 
The main goals of this lab exercise are to familiarize students with: 

• Options for creating dense point clouds 
• Classification of point clouds and estimation of ground points 
• Creation of surface and terrain models 
• Calculation of area, volume, and surface profiles 

In the previous lab we added the ground control and made a rock-solid stereo model for the Parker Farm site. 
The last thing we did for that lab was to create the dense point cloud. The dense point cloud is the first of the 
real products that come from the structure from motion (SfM) workflow. The 3D (dense clouds, mesh surfaces) 
and 2.5D (elevation models) outputs from SfM are very rich and useful data products. In this lab we’ll look 
deeper into how to create these products and some tools to help make and use them. 

Deliverables 
Fill out and submit the questions document when you have completed the lab exercise. 

Note: Please refer to the class Canvas site for lab due dates. You may work together and help each other, but 
please make sure what you turn in is your own work. 

Section 1: Creating and Classifying Dense Point Clouds 
At the end of the previous lab, you should have created a dense point cloud for the Parker Farm Site. Hopefully 
you saved your Metashape project from the last lab! 

1. Open the project you saved at the end of the previous lab. First things first, choose File -> Save As from 
the main menu and save it as a new project for this lab exercise. This is good insurance in case 
something goes wrong, you still have your original project to revert to. 
 

2. The first thing we want to do is define a smaller area to work with. The goal will be to restrict the 
analysis to the field between the road and the woodlot, the woodlot, and a bit of the field past the 
woodlot (see figure below). This will do two things: 1) it cuts down on processing time because there’s 
less area to deal with, and 2) it trims out the ragged edges from the model where we don’t have great 
photo overlap and the quality of the model isn’t all that good. 
 

a. Go to the Model View and click the button to view the dense point cloud  (if you don’t have a 
dense point cloud, then go back to lab 5 and make sure you complete the final steps to create 
the dense cloud). 
 

b. From the toolbar at the top of the Metashape application window, click on the dropdown arrow 
shown below. These are tools for changing the analysis region. Select the Resize Region tool and 
grab the blue dots at the corners of the region to resize it. You may need to rotate the region to 
get it to fit nicely with the “Rotate Region” tool. If you completely mess up the region, you can 
choose the Reset Region option. Hint #1: the region can be hard to see on top of the dense point 
cloud. Toggling back/forth to the sparse point cloud helps you see the region better. Hint #2: the 
region is 3 dimensional, so once you’ve resized it, spend some time looking at it from all sides 
(top, side, bottom) to make sure the area you want is actually inside the region.  
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c. With the region set, all subsequent products (DEMs, Meshes, Orthos) will be calculated for the 
area in the region only. 
 

3. At this point we have our best performing model (unless you want to keep tweaking with the markers), 
and we’re ready to start building our final products. For this week, we’ll create the dense point cloud. 
From the Workflow menu, choose Build Point Cloud. You can leave the options set to their defaults. 
Quality refers to the total number of points that will be generated in the dense cloud. High and Highest 
can take a LOOOONG time. Depth filtering refers to how/if Metashape will do any screening out of 
points from the dense cloud. If you need fine details for things like vegetation, you might choose 
“none.” Otherwise, Mild is generally fine. Calculate point colors just assigns the nearest photo pixel 
color value to the points which makes a pleasing looking point cloud. When you’re ready, click OK. 
NOTE: This process may take quite a while to run depending on your computer.  
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4. Now we want to try to figure out which of the points in the dense cloud are ground points and which are 
not (e.g., vegetation, buildings, etc.). This is not an exact science, and a good bit of trial/error are 
required. In fact, you may get better results exporting the dense cloud and classifying it in another 
application like Fusion, CloudCompare, or R. 

a. To classify the ground control points, from the main menu, select Tools -> Dense Cloud -> 
Classify Ground Points. This will open the following dialog box. 

 
 
The concept behind this tool is that Metashape finds the lowest elevation within a square grid 
cell (you set the size of the grid) and looks at the angle and/or distance from the plane defined 
by that lowest elevation to tell whether any given point in the dense cloud is a ground point or 
not a ground point. The options are: 
 
Max angle: This is the maximum angle from the “ground plane” any point can be and still be 
considered to be a ground point. See image below for an example. For flat areas, you can 
choose a very small angle. For steep or rugged areas, you’ll need a bigger angle to avoid 
misclassifying ground as something else. 

 
Conceptual schematic of how Metashape identified ground points from a dense cloud. The lowest point in the grid cell 
(size set by the user) defines the ground plane. All points are evaluated against this ground point, and those whose 
angle from the ground point is less than the maximum angle OR those that are less than the max distance are 
considered to be likely ground points. 
 
Max distance: This is the maximum distance any point can be from the ground plane and still be 
considered a ground point. Like the angle, the flatter the area the smaller a max distance you 
can select. 
 
Cell size: This is the size of the grid cell that Metashape will use to determine the lowest 
elevation that becomes the ground plane. This parameter does NOT mean the resolution of the 
final product. Generally, you want the cell size to be large enough so that any grid cell will have 
at least some ground in it (i.e., you wouldn’t set it so small that all points in a grid cell are within 
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tree canopy. 

 
Conceptual illustration of the cell size option for classifying ground points. The lowest point in each grid cell is 
considered to be the ground point against which all other points are evaluated. For this reason, grid cells need to be 
large enough so that every cell will have ground areas in it. In the case of the Parker Farm dataset, grid cells of about 
30m will all contain at least some ground in them. Note the grid cells shown here are both approximate and 
hypothetical. 
 

b. Play around with different values for max angle and distance with a cell size set to 30m. Start 
with the default values of 7.5 degrees for max angle and 1m for max distance. 

i. Once you run the ground point classification, you need to filter the dense cloud, so you 
are seeing only the points classified as ground. From the main menu, choose Tools -> 
Dense Cloud -> Filter by Class.  

ii. Within the dialog box that opens, uncheck all the classes except for Ground and click 
OK. Hint: hold down the shift key to select multiple classes at once. With the shift key 
held down, clicking on one of the check boxes will turn on/off all the selected classes. 

 
 

iii. Evaluate the results of the ground point classification. Odds are you won’t like the 
results the first few times. If tall vegetation is still being classified as ground, reset the 
classification (Tools -> Dense Cloud -> Reset Classification) and reset the filtering (Tools 
-> Dense Cloud -> Reset Filter) and repeat the classification process using a lower max 
angle and max distance.  
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iv. Repeat the process until you have a ground classification result you are happy with. 

Section 2: Surface and Terrain Models 
With our dense point cloud classified into ground and non-ground classes, the next step is to create our digital 
elevation models (DEMs). There are two main classes of DEMs. Digital surface models (DSMs) estimate the 
elevation of the top of whatever the highest surface is. Digital terrain models (DTMs) attempt to estimate the 
elevation of the ground whether it is exposed/visible or under another object. Obviously good DTMs are pretty 
tricky to create if the ground is obscured. This is one application where an active sensor like LiDAR is 
advantageous over photogrammetric techniques. Nonetheless, we’ll create both a DSM and DTM from our 
dense cloud and then use them to estimate a canopy height model (CHM). 

5. From the main menu, choose Workflow -> Build DEM. This will open the Build DEM dialog box. We’ll 
make the DSM first. 

 
 

a. For the projection, choose NAD83/UTM Zone 11 (that’s where we are). Note: Metashape will let 
you create raster products like DEMs and Orthomosaics in a geographic coordinate system (e.g., 
WGS84), but you really should use a projected coordinate system. Reason being is that a 
geographic coordinate system uses and angular unit (degree) which is a really lousy unit for 
distance (among other things, the size/shape of the grid cells will change as you move 
north/south from the equator). Projected coordinate systems use linear units (e.g., meters) 
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which are much better for measuring distances, areas, and directions. 
 
The source data will be the Dense Cloud. Interpolation should be enabled, and we want to use 
all point classes.  
 
Don’t worry about setting a region. You did that already in Section 1. You can leave the 
resolution at it’s default of ~ 5.7cm 
 
Click OK when you’re ready, and Metashape will calculate your DEM. 
 

b. The resulting DEM should include heights for the trees and other vegetation in the scene. 
Reminder: Display the DEM by double-clicking on it in the Workspace pane or clicking the DEM 
button in the main toolbar. 

 
 

c. Now we want to create the DTM. The problem here is that if you run the Build DEM function 
again, Metashape is going to overwrite the DEM/DSM you just made (that’s annoying, but hey, I 
didn’t write the software). The workaround for this is to Duplicate the DEM. To do this, right-
click on the DEM in the Workspace Pane and choose Duplicate from the menu. 

 
 
This is going to create a copy of the DEM (helpfully called DEM). 
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So which DEM is Metashape going to rewrite? It’s the one that is set as the default. Notice that 
when you right click on the DEM that in the context menu, one of them will have a check mark by 
Set as Default. Also notice that one of the names is in italics font and the other is normal. The 
italicized name is the copy. Metashape will overwrite the one with its name in normal font 
because that is the default DEM. Clear as mud, right? You can rename the copy by right-clicking 
on it and choosing Rename. Calling it something like DSM is a good idea. For the next step, make 
sure that your DSM is NOT active. 
 

d. After you’ve copied the DEM/DSM, we will make the DTM. Go to Build DEM again and this time, 
click Select for the point classes. Uncheck all of the classes except for Ground and click OK. Then 
click OK to build the DTM using only the ground points. Hint: Make sure you set your projection 
the same as your DSM. 

 
 
Your resulting DTM should look a lot different than the DSM. Notice the interpolated areas. 

 
 

e. The last thing we want to do here is create a CHM. To do that, right-click on the DSM and 
choose Transform DEM from the menu. 
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In the transform DEM dialog box, check the box for Calculate difference and from the dropdown 
list, choose your DTM (Why? Because this model already has the values from the DSM in it 
because that’s what you copied it from). Don’t worry about the region or resolution options. 
Click OK to calculate the difference between the DSM and the DTM (i.e., canopy height model). 

 
 
Metashape will ask if you want to replace the default DEM. Choose No to have it write the CHM 
out to a new DEM layer. 
 
The resulting CHM will look visually very similar to the DSM (though there are subtle differences 
in the ground areas), but notice that the scale is much different. It will look from the scale like 
the ground values are negative, but they actually have a value of zero. 
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Section 3: Calculating profiles, areas, volumes 
The last thing we want to do for this lab is to create some shapes and calculate some statistics. We should 
recognize, though, that Metashape isn’t necessarily the sharpest tool in the shed for these analysis steps. You 
can do some basic calculations, but if you need anything sophisticated, you should export your products and run 
your calculations in another application. 

To take measurements of perimeter, areas, and volume, or to create elevation profiles, you must first create a 
Shape. In brief, a Shape in Metashape is just a point, line, or polygon. You can create shapes in either the model 
view or the ortho view using the Draw shape tools in the main toolbar. 

 

6. Create a line over the CHM by choosing the Draw Polyline tool. Click on the CHM where you want to 
start the line, left-clicking adds vertices to the line, and double-clicking ends the line. Your line can be as 
simple or complex as you want. When you end the line, Metashape will present a dialog box where you 
can add/change the attribute values for the shape. For now, leave these as the defaults and click OK to 
save the line. 

 
 

a. Switch back over to the navigation tool , and single-click on the line to select it (it will show 
as red when it is selected). Right-click on the line and choose Measure from the menu. 
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Note that the DEM extent for this example is different/smaller than what you should have by following 
the directions above. 
 
This will open a measurements dialog box. The first tab contains information on each of the 
vertices for the line and the total length of the line (i.e., perimeter). The second tab gives an 
elevation profile for the line. Save the profile graph using the save icon in the upper right corner 
next to the graph (you’ll include it in your responses to the questions below). Make sure you set 
the save file format to either JPG or PNG. 

 
 

b. Now repeat the steps above, but create a polygon that contains all or a part of the forested 
woodlot. When creating your polygon, it is important that the vertices (corners) of the polygon 
are ALL on ground locations, not on vegetation. After you have created your polygon, switch 
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back to the navigation tool, select the polygon, right-click, and choose Measure… from the 
menu.  
 
In the first tab you will see statistics for the perimeter and area of the polygon. The second tab 
will give you an elevation profile for the perimeter (not very useful in this context). The third tab 
will give you the volume calculations. 
 
For calculating volume within a polygon, you have three choices for how Metashape will 
determine where the base level is from which volume will be calculated. 
 
Best Fit Plane: Uses the elevations for each of the polygon vertices and creates an interpolated 
surface between them. Useful for many applications where you have a relatively level ground 
surface. 
 
Mean: Uses the mean elevation of the vertices to estimate the base level. Really only works if 
the ground surface is flat or you want volume above/below a fixed elevation. 
 
Custom: The user inputs an elevation to be used as the base level. 

 
Note that the DEM extent for this example is different/smaller than what you should have by following 
the directions above. 
 
Choose Best fit plane and note the volume of the tree canopy above that plane. 
 

7. Make sure to save your project before you quit. The next lab will pick up at this point. 
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