Lab 11: Close-range Photogrammetry

Objective
The main goals of this lab are to familiarize students with:

e How structure from motion (SfM) photogrammetry can be applied to 3D object scanning
e Tools in Metashape for modeling 3D objects from 2D photographs
o Working with 3D meshes for modeling objects and calculating volume and surface area

To this point, we’ve worked exclusively with drone imagery to create map products from aerial
photographs. However, the SfM techniques work the same for creating 3D models of objects from
regular photographs too. The approach is slightly different, where you either orbit an object, taking
pictures from all sides (not too different from what we might do from a drone), or you keep the camera
in a fixed location and rotate the object (much different than what we typically do with a drone!). In this
lab, we're going to create a 3D model of my Darth Buddha figurine that was created on a 3D printer.
We'll create a 3D model and then estimate the volume of Darth Buddha.

Deliverables
Fill out and submit the questions at the end of this document. No need to submit a quality report from

Metashape.

Section 1: Load photos and set coordinate system
1. Download the images that we’ll need for this lab from the following link:
https://vandalsuidaho-
my.sharepoint.com/:u:/g/personal/jkarl uidaho edu/EX67FJ22XE9PodWMaY7sg6sBDZ2cs2cQL
gGLN8A69b5WBg?e=2MSWpk

2. Also, download the following files from the class BBLearn site and save them to the folder where
you’re going to save the Metashape project for this lab:
a. Turntable_Targets_Metashape_Markers.csv
b. Local_mm.prj

3. Open a new Metashape project and load the photos for this lab.

4. With all our past Metashape projects, we’ve worked with drone imagery that had geographic
coordinates associated with it (or for which geographic coordinates were appropriate). For this
lab, though, geographic coordinates aren’t appropriate for two reasons: 1) we’re working at a
very fine scale to model an object, and 2) the camera is fixed and the object is being rotated. For
these reasons, we need to establish a local coordinate system for this project. Metashape has
one local coordinate system available, but its units are in meters — which is also too coarse for
what we’re doing. So, we’ll load up a new coordinate system that uses millimeters for units.

From the reference pane, click on the Reference Settings button.


https://vandalsuidaho-my.sharepoint.com/:u:/g/personal/jkarl_uidaho_edu/EX67FJ22XE9PodWMaY7sg6sBDZ2cs2cQLgGLN8A69b5WBg?e=2MSWpk
https://vandalsuidaho-my.sharepoint.com/:u:/g/personal/jkarl_uidaho_edu/EX67FJ22XE9PodWMaY7sg6sBDZ2cs2cQLgGLN8A69b5WBg?e=2MSWpk
https://vandalsuidaho-my.sharepoint.com/:u:/g/personal/jkarl_uidaho_edu/EX67FJ22XE9PodWMaY7sg6sBDZ2cs2cQLgGLN8A69b5WBg?e=2MSWpk
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5. Notice the Coordinate system is set to WGS 84 (EPSG::4326). This is the default for GPS
coordinates that are normally associated with drone imagery.

Click on the down arrow and choose “More...”

v Reference Settings X

Coordinate System
WGS 84 (EPSG::4326)
[ Camera reference
WGS 84 (EPSG::4326)
[ Marker reference

WGS 84 (EPSG::4326)

Rotation angles: Yaw, Pitch, Rol hd
Measurement Accuracy Image Coordinates Accuracy

Camera accuracy (m): Marker accuracy (pix):
Camera accuracy (deg): Tie point accuracy (pix):

Marker accuracy (m): 0.005
Scale bar accuracy (m): (0.001

Miscellaneous

Capture distance (m): |
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6. This dialog box lists all the available coordinate systems (yes, there are a lot of them!). However,
the one we want isn’t there. Click on the folder icon and select the Local_mm.pr;j file. Click Open.
Click OK to close the Select Coordinate System dialog.



elect Coordinate Systemn *
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h%inate System Authority ~
VN-2000 EPSG:4756
Vanua Levu 1915 EPSG:4748
Vientiane 1982 EPSG:4676
Viti Levu 1912 EPSG:4752
Viti Levu 1916 EPSG:4731
Voirol 1875 EPSG:4304
Voirol 1875 (Paris) EPSG:4811
Voirol 1879 EPSG:4671
Voirol 1879 (Paris) EP5G:4821
WGS 66 EPSG:4760
WGS 72 EPSG:4322
WGS 72BE EPSG:4324
WGS 84 EPSG:4326
WGS 84 (G1150) EPSG::9055 %

Geographic Coordinate System: WGS 84 (EPSG::4326)
Angular Units: degree (EPSG::9102)

Geodetic Datum: World Geodetic System 1984 (EPSG::6326)
Elipsoid: WGS 84 (EPSG::7030)

Prime Meridian: Greenwich (EP5G::8901)
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7. You'll notice that the coordinate system is now changed, but all the units on the Reference
Settings dialog are still set to meters. We need to accept the change and then reopen this dialog
to see the changes.

Click OK to accept the change of coordinate system and then reopen the Reference Settings
dialog box.

8. Notice now that the units on this page (e.g., Camera accuracy) are now listed in millimeters.
Because we’re confident that the camera position is fixed and the reference markers on the

turntable are accurately placed and measured, we can dial in our measurement accuracies.

Change the Camera accuracy to 100 and the Marker accuracy to 10. Click OK to close this dialog



box.
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Section 2: Masking and aligning the photos

Before we can align the photos, we need to deal with the background of the photos that doesn’t move
as the turntable is rotated. We need to instruct Metashape to ignore this part of each photo otherwise it
will interfere with the alignment process (i.e., the photos won’t align). We do this by creating a mask.

1. Open one of the photos by double-clicking on it in the Photo Tray.
2. From the main toolbar, click the drop-down next to the selection tool and choose the Intelligent

Scissors tool.
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3. Use the Intelligent Scissors tool to digitize a polygon around the circle of the turntable, staying
on the white part. No need to be super precise here, just get the basic shape.



4. This tool has created a selection of the area WITHIN the polygon. We need to mask the area

OUTSIDE the polygon. To do that, we need to invert the selection.

From the main menu, choose Edit, Invert Selection.
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Now add the selection (which includes everything EXCEPT for the turntable) to the mask by
clicking on the Add Selection button on the main toolbar.

File  Edit  View Workflow Model Photo Orthe Tools Help
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Your finished mask should look something like below. Note that the shaded-out portion is
masked out and will not be considered for matching tie points.

Also note, because we have a mask region that is very consistent among our photos, we only
need to create the mask on one photo. If the background changed between photos (i.e., the
object was stationary and we moved around it to take the photos), we would need to create a
separate mask for each photo.

Now we can align the photos. From the main menu, choose Workflow -> Align Photos.

This process is pretty much like we’ve done before with just a couple of changes. First, there is
no geographic coordinate information for the photos, but the photos are in sequence, so choose
Sequential from the drop-down menu. Second, change the option to apply masks to the Tie
Points. Check the other options against the figure below, then click OK.
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8. When your photos have aligned, you should have a sparse point cloud that looks something like
this. The orientation of the sparse cloud may be off. This is because there is no reference



information yet to tell Metashape which direction is up. We’ll add that next.

Section 3: Detecting markers and adding “ground” control

The next step is to add some “ground” control. This will scale the model so we can get accurate
measurements and will tell Metashape how to orient the model (i.e., which way is up). The targets and
the grid on the turntable are critical for this (and actually make it pretty easy!).

1. The first step is to have Metashape detect the targets on the turntable. From the main menu,
choose Tools -> Markers — Detect Markers.

1 Tools  Help

I Markers b Detect Markers...
Tie Points b Detect Fiducials...
| Dense Cloud > Print Markers...
Mesh b Track Markers...
DEM r
] Attach Markers
Qrthomosaic r i
Refine Markers
Lens r

2. Make sure the marker type is set to Circular 12-bit, and set the tolerance all the way up to 100.
Click OK, and Metashape will scan each of the photos for the targets and create a marker for



each one.

A Detect Markers x
Parameters
Marker type: Circular 12 bit <
Tolerance: I
Maximum residual (pix): 5

Process selected cameras only
Ignore masked image regions
[ Inverted (white on black)
[] Disable parity
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Open several of the photos to see how well Metashape did at identifying the targets.

For some reason, it seems to have trouble identifying target 2 in some photos. In these cases,
you can manually place the marker on the photo by right-clicking where the marker should go
and choosing Place Marker (note: make sure you’ve switched back from the Intelligent Scissors
tool to the navigation (pointer) tool).
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Spend some time looking through the remainder of the photos checking and where necessary
fixing the markers.

With the markers identified on the photos, we next need to import the coordinate information.
The grid on the turntable establishes a Cartesian coordinate system with it’s origin (0,0 point) at
the center of the turntable (under Darth Buddha). From the reference window, click on the
Import Reference button.
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Import the Turntable_Targets_Metashape_Markers.csv file. Make sure you set the Coordinate

System to Local (mm) and set the columns to match the data in the file. Click OK to import the
coordinates for each target/marker.
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6. Everything should update to reflect the new coordinate information, but it’s not a bad idea to
hit the refresh button on the Reference toolbar just in case.
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Section 4: Resizing the region and building a mesh

At this point with a normal drone mapping project, we would build a dense point cloud, then a DEM and
orthomosaic. For this application, though, a Mesh 3D model is going to be more helpful. Before we get
there, it's helpful to shrink the analysis region to get rid of some unnecessary parts.

1. From the main toolbar, click on the Resize Region button (you may need to use the drop-down
arrow to get to this tool.

DB 9k - A~

2. Shrink the analysis region by grabbing the corners of the box and dragging them in toward the
center. Try to just trim off the outside of the turntable. If you make it too small, Metashape
won’t be able to build the Depth Maps it needs to make the Mesh model. If that happens (you’ll
get an error box), make your region bigger.



3. Make sure you view the region from the side too. If the region does not extend all the way up
the sparse cloud, the model will cut Darth Buddha's head off!




4. When the region has been set, choose Workflow -> Build Mesh from the main menu.
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5. The 3D mesh model should look something like below.

Section 5: Trimming the mesh and calculating volume
The final step for this lab is to estimate the volume of the Darth Buddha. To do this, we’ll first want to
trim the rest of the turntable off of the model.

1. Use one of the selection tools from the main toolbar to select Darth Buddha and a little of the
surrounding turntable surface. Then from the main menu, choose Edit -> Invert Selection. This
will switch the selection to the rest of the turntable and leave Darth Buddha and the nearby
turntable parts unselected.
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2. Click the delete button on the main toolbar to delete the selected portions of the turntable (not
Darth Buddhal!).
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3. Zoom in around the base of Darth Buddha and select the remaining patches of turntable and
delete them. You should be left with a relatively clean model of just Darth Buddha.

4. At this point, if you turn Darth Buddha upside down, you'll see that he’s hollow. To calculate the
volume, we need to have a solid/enclosed model. To do that, from the main menu, choose Tools
-> Mesh -> Close Holes.
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5. Set the level to 100% and click OK.
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Level:
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6. You should now see that Darth Buddha is solid.

7. The last step for this lab is to calculate the volume. From the main menu, choose Tools -> Mesh -
> Measure Area and Volume.
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8. The volume in cubic millimeters will be shown. Convert this to cubic centimeters by dividing it by

1,000.
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Lab Questions to Answer
Please answer the following questions and where appropriate provide justification for your answers.

1. What was your volume estimate for Darth Buddha (please make sure to include the units)?

2. Include a screenshot of your Darth Buddha mesh model.

Lab Grading Rubric

Question Points
1 /15
2 /15

Total /30
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